Home > Cannot Open > Libgtk-3.so.0: Cannot Open Shared Object File: No Such File Or Directory

Libgtk-3.so.0: Cannot Open Shared Object File: No Such File Or Directory

Contents

Comment 45 weliot 2012-12-07 00:57:36 PST (In reply to Mike Hommey [:glandium] from comment #44) > FWIW, I can't reproduce on debian squeeze with the Firefox 17.0.1 builds, > neither on Unfortunately the magic described above in my opinion is not for ordinary users who want to work on Linux with the programs which they have already used to. Command LD_DEBUG=libs /home/dell/Programs/seamonkey/seamonkey showed that 32-bit SeaMonkey while being launched looked for some dynamic libraries among 32-bit directories (/usr/lib/i386-linux-gnu for example) and 64-bit SeaMonkey among 64-bit directories (/usr/lib/x86_64-linux-gnu correspondingly). How to remove text field value after comma using apex code? have a peek here

Reporting issues to a closed bug in bugzilla, especially one closed so long ago, is probably the worst way to do that. opensuse 13.1 RC1 Aurora 26 Comment 40 lainiwaku 2013-10-19 09:52:51 PDT lain@EVA:~$ /opt/firefox/firefox XPCOMGlueLoad error for file /opt/firefox/libxul.so: libdbus-glib-1.so.2: cannot open shared object file: No such file or directory Couldn't load Comment 17 Tony Mechelynck [:tonymec] 2012-11-23 13:11:57 PST Also with SeaMonkey nightlies: Good: 20121122003007 http://hg.mozilla.org/mozilla-central/rev/3b71d63eafd5 http://hg.mozilla.org/comm-central/rev/99fd4744910d Bad: 20121123100213 http://hg.mozilla.org/mozilla-central/rev/4d832dcd0be9 http://hg.mozilla.org/comm-central/rev/e2ec99c4e48a Trying to start the program, I get (on stdout+stderr log): XPCOMGlueLoad x220:/tmp/firefox$ find -name libxpcom.so ./libxpcom.so x220:/tmp/firefox$ ./run-mozilla.sh run-mozilla.sh: Cannot execute . https://bugzilla.mozilla.org/show_bug.cgi?id=723487

Libgtk-3.so.0: Cannot Open Shared Object File: No Such File Or Directory

Maybe you should check the list of your installed vs. What happens here is Firefox failing to work on 3-4 year old Linux operating systems. Running without an active 'av' is a bad idea. There are two related problems here resulting in people getting the wrong version of firefox which results in them thinking that there is a software bug in it.

  • According the http://www.mozilla.org/en-US/firefox/20.0/system-requirements/ Windows XP SP2 is supported.
  • I'm not taking this discussion anywhere else since I still remember what happened with the sys requirements in 2008, that caused horrible problems for many Linux users, and how it was
  • Can I cite email communication in my thesis/paper?
  • First I downloaded the thunderbird from the main site, by clicking download.
  • Going back to your original concern about "submeaning".
  • [email protected]:~$ Using Opera for the time being but I would like to get Firefox back as soon as possible Edit:Firefox has been running on 14.04 for me for over a year

available packages to see if Kubuntu doesn't do something similar? Anthony Hughes, I asked for assistance in reporting the problems mentioned in my previous post, but instead of that you just cleared the meaning of your title. Then seamonkey 2.15.1 works correctly. Libgtk-3.so.0: Cannot Open Shared Object File: No Such File Or Directory Couldn't Load Xpcom. I also have fluxbox and KDE installed.

If so, can you please run LD_DEBUG=libs ~/firefox/firefox And see if there's anything interesting in the output? I have to go out for a while... As appeared Kubuntu 12.10 AMD64 distribution contains a number of libraries needed for SeaMonkey and Firefox only in their 64-bit versions. Sweet icons by famfamfam.

Very inadequate behaviour for the package that is supposed to run out of the box... :(( Comment 29 :aceman 2013-02-07 09:11:35 PST Can you see if any hints in bug 723487 Libxcomposite.so.1: Cannot Open Shared Object File: No Such File Or Directory I'm wondering why I was forced to "use pliers to pull out the words out of your mouth (figuratively speaking, it's an expression used in my country) in order to receive apt-get install ia32-libs-gtk 9 Comments for this entry Vitaliy July 10th, 2012 on 11:50 Thanks, it works! We don't support specific distributions, instead we support different platform configurations (kernel, libraries, etc).

Libdbus-glib-1.so.2: Cannot Open Shared Object File: No Such File Or Directory

try: yum install libvpx share|improve this answer edited Nov 20 '14 at 1:12 slm♦ 168k42310481 answered Nov 20 '14 at 1:06 tingli 11 add a comment| up vote 0 down vote Comment 13 Joey Twiddle 2012-07-13 20:27:41 PDT I had this error running the normal 32-bit Firefox on 64-bit Debian squeeze, with ia32-libs installed. Libgtk-3.so.0: Cannot Open Shared Object File: No Such File Or Directory I would be doing you a disservice to suggest otherwise or to ignore cries for help altogether. > There are two related problems here resulting in people getting the wrong > Libxul.so Firefox Format For Printing -XML -JSON - Clone This Bug -Top of page Home | New | Browse | Search | [help] | Reports | Product Dashboard Privacy Notice | Legal Terms

Just in case it helps anyone. navigate here assuming that's a 32 bit binary, my question inside the strace log (middle) is still valid: why does FF stop looking in the path where it is located, and start looking That said, I HATE IE... :) PS: are there ff{8,9,10} 64bit binaries? Global.asax Application_Start not hit after upgrade to Sitecore 8.2 How to interpret torque spec ranges? Libgio-2.0.so.0: Cannot Open Shared Object File: No Such File Or Directory

Comment 34 Sebastian Freundt 2013-03-02 11:28:43 PST Same problem, showing in firefox-22.0a1.en-US.linux-i686.tar.bz2 Attached is LD_DEBUG=all output Comment 35 Sebastian Freundt 2013-03-02 11:30:09 PST Created attachment 720314 [details] LD_DEBUG=all output of failing Mathew Hodson (mathew-hodson) on 2015-07-09 Changed in firefox (Ubuntu): status: Confirmed → Invalid Rednet (arhgs2014) wrote on 2016-04-02: #16 i confirm i still have this bug See full activity log To LOL "." in $PATH is deprecated as a safety measure; forces user to explicitly specify ./proggy if that's desired... http://haywirerobotics.com/cannot-open/error-while-loading-shared-libraries-libclntsh-so-10-1-cannot-open-shared-object-file.html Not the answer you're looking for?

I have not done anything recently other than run apt-get dist-upgrade and do not know what could be causing this. Libasound.so.2: Cannot Open Shared Object File: No Such File Or Directory But it's now a little bit different. I have version 38.0+build3-0ubuntu0.14.04.1 installed Mike Driscoll (qike) wrote on 2015-06-26: #5 I had Firefox open this morning on Xubuntu 14.04 , but it became unresponsive.

share|improve this answer answered Nov 16 '15 at 15:43 starfry 1,83311732 add a comment| Your Answer draft saved draft discarded Sign up or log in Sign up using Google Sign

I tracked down that libicui18n.so.54 is in the icu (International Components for Unicode library) package, so I updated that package. Comment 107 Jim 2014-09-21 04:41:44 PDT (In reply to Syed M Shaaf from comment #39) > Okay I can confirm. > > 1. Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Firefox/24.0; Build ID: 20130829135643 OK Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0; Build ID: 20130901030218 OK Comment 38 andré 2013-09-06 15:12:21 PDT (In reply to Libdbus-glib-1.so.2: Cannot Open Shared Object File: No Such File Or Directory Couldn't Load Xpcom. In several iterations I added via Synaptic from reps the following requested 32-bit version packages: libdbus-glib-1-2:i386 (ver 0.100-1) libpango1.0-0:i386 (ver 1.30.1-0ubuntu3) libgtk2.0-0:i386 (ver 2.24.13-0ubuntu2) After that SeaMonkey finally loaded with double

SP2 is from 2006? Been doing that for years. Thank You Comment 25 andré 2013-01-26 11:54:57 PST Had the same error message for seamonkey 2.14.1 and 2.15.1 after installing on a new 64-bit machine. 2.14.1 had worked ok on my http://haywirerobotics.com/cannot-open/fatal-error-c1083-cannot-open-include-file-39-thread-39-no-such-file-or-directory.html Comment 10 Pierre Fortin 2011-11-22 16:32:55 PST re comment 8: Already stated in comment 1: > Tried versions 8, 9, 10 and 11... > the only one that works on my

Once again, I try to relaunch the Mozilla Firefox, and you know what? Comment 77 c1620979 2013-02-22 09:43:08 PST I have trouble with firefox 19.0 $ uname -a Linux bi-desktop 2.6.28-19-generic #66-Ubuntu SMP Sat Oct 16 17:39:04 UTC 2010 i686 GNU/Linux $LD_LIBRARY_PATH=`pwd` ./firefox XPCOMGlueLoad As I said before, there is nothing more to be done in *this* bug report. mozilla Ask a question Sign In English Search Home Support Forum Firefox Couldn't load XPCOM.

Downloaded here: ftp.mozilla.org/pub/mozilla.org/firefox/releases/18.0/linux-i686/de/ Error message: > firefox XPCOMGlueLoad error for file /opt/MozillaFirefox18_0/libxpcom.so: libxul.so: cannot open shared object file: No such file or directory Couldn't load XPCOM. When applied to nightlies starting with 2012-09-21-03-06-01-mozilla-central the command outputs lines which indicates the use of the GNU extension. Comment 89 contenetcom@yahoo.com 2013-06-12 11:54:51 PDT (In reply to pvelkovski from comment #25) > Try downloading Firefox manually from ftp://ftp.mozilla.org/pub, and make > sure to choose the 64 bit version. Results 1 to 8 of 8 Thread: Firefox is completely broken ,,,can't reinstall Thread Tools Show Printable Version Subscribe to this Thread… Display Linear Mode Switch to Hybrid Mode Switch to

Thank you! NOTE that the original report was libxul.so, and with: LD_LIBRARY_PATH=`pwd` ./firefox it's libXrender.so.1 that's complained about here... Comment 105 lorenzo.decarli 2014-04-11 14:35:33 PDT Agreed. I'm a ff advocate, not just a regular user -- I don't like seeing easily avoidable targets that can harm its reputation...

How safe is 48V DC? Please fix this *ASAP*! Issue started for me this morning, as well. Maybe it should be resurrected?

You can try the 64 bit version. Edit bug mail Other bug subscribers Subscribe someone else • Take the tour • Read the guide © 2004-2016 CanonicalLtd. • Terms of use • Contact Launchpad Support • Blog That solved it. Cleaned up my .bashrc and alls well.

export LD_LIBRARY_PATH=/usr/lib64/:/lib64:$LD_LIBRARY_PATH After this point, when I did yum help or yum install firefox (it didn't give the above error) BUT: firefox --version still gave the error: XPCOMGlueLoad error for file How to rectify this error? Comment 43 Mike Hommey [:glandium] 2012-12-06 10:04:13 PST Firefox 17.0.1 32-bits build: $ objdump -T libxul.so |grep _ZNSbItN4base20string16_char_traitsESaItEE4_Rep20_S_empty_rep_storageE 01c2fb90 w DO .bss 00000010 Base _ZNSbItN4base20string16_char_traitsESaItEE4_Rep20_S_empty_rep_storageE Firefox 17.0.1 64-bits build: $ objdump pierre@hg ~ 18:46:57 $ ff 8.0.1 /usr/local/bin/firefox8.0.1 XPCOMGlueLoad error for file /home/usrlocal/bin/firefox8.0.1/libxpcom.so: libXrender.so.1: cannot open shared object file: No such file or directory Couldn't load XPCOM.