Home > Configure Error > Configure Error Cannot Find Libpq-fe.h

Configure Error Cannot Find Libpq-fe.h

Solution: yum install libc-client-devel ERROR IX : checking for LDAP support… yes, shared checking for LDAP Cyrus SASL support… yes configure: error: Cannot find ldap.h Solution: yum install openldap-devel ERROR X You can find this with the command: $ sudo find / -iname pg_config Save the file: $ sudo chmod +x /etc/profile.d/ruby.sh and try to execute your command again. I symlinked the pg_* scripts into the path like so: ln -s /usr/pgsql-9.3/bin/p* /usr/local/bin. HelloWorld Community Any senior Drupal devs out there interested in working in/moving to Vietnam, or Switzerland, or Netherlands? Source

Flink ? You may need configuration options. I tracked libpq-fe.h to '/Applications/Postgres.app/Contents/Versions/9.3/include' and used the export command with said path, followed by the 'gem install pg' and the gem installed successfully. –Ryan Spears Apr 11 '14 at 12:13 sudo /sbin/SystemStarter stop postgresql-8.4 sudo rm -rf /Applications/PostgreSQL\ 8.4 sudo rm -rf /etc/postgres-reg.ini sudo rm -rf /Library/StartupItems/postgresql-8.4 sudo rm -rf /Library/PostgreSQL/8.4 sudo dscl . http://stackoverflow.com/questions/6040583/cant-find-the-libpq-fe-h-header-when-trying-to-install-pg-gem

sudo apt-get install libmcrypt-dev configure: error: Cannot find OpenSSL's libraries Add following switch to your ./configure options (optionally updating the path to reflect your system):--with-libdir=/lib/x86_64-linux-gnu configure: error: You've configured extension pdo_sqlite Ballpark salary equivalent today of "healthcare benefits" in the US? Results logged to /var/lib/gems/1.8/gems/pg-0.14.1/ext/gem_make.out An error occurred while installing pg (0.14.1), and Bundler cannot continue. How to change Direct admin's default port number?

Meanwhile, my solution was to put this in my ~/.R/Makevars: PKG_CPPFLAGS=$(shell pkg-config libpq --cflags) PKG_LIBS=$(shell pkg-config libpq --libs) I expect you can use that to replace a lot of custom config Thanks!! It's one of those cities I'd love to move to, and would defo consider it, but then again... Developer does not see priority in git Development Workflow being followed Why does low frequency RFID have a short read range?

For example, with the 9.4 release (current as of this writing), all you need is: export CONFIGURE_ARGS="with-pg-include=/Applications/Postgres.app/Contents/Versions/9.4/include" gem install pg This will keep your pg gem in sync with exactly the Why is this C++ code faster than my hand-written assembly for testing the Collatz conjecture? no Can't find the 'libpq-fe.h header *** extconf.rb failed *** Could not create Makefile due to some reason, probably lack of necessary libraries and/or headers. http://stackoverflow.com/questions/9668753/rails-3-cant-install-pg-gem Not the answer you're looking for?

share|improve this answer answered Feb 17 '15 at 14:16 joh-mue 706 add a comment| up vote 3 down vote I found this answer, and it was the only one that worked Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count). Jump to navigation Search form Search How to install PHP 5.3 and 5.2 together on Ubuntu 12.04 3 August 2012 PHPApacheUbuntuLinuxsysadmininstallationDrupalDrupal PlanetAlthough Drupals 7+ run smoothly on PHP 5.3, Drupal 6 One way of doing it is using mod_php5 Apache module to serve PHP 5.3 applications, while running PHP 5.2 applications using fastcgi module.

  • Please check your libxml2 installation.
  • I soft-linked gcc to gcc-4.2 and it worked: sudo ln -s /usr/bin/gcc /usr/bin/gcc-4.2 Why was it trying to use gcc-4.2?
  • For detailed instructions of how I got things going (which may not be the easiest or best way to do things), start here: http://northwestspatial.com/wp/?p=328 share|improve this answer answered Apr 25 '13

For me, the magic command line was: sudo yum install postgresql93 postgresql93-server postgresql93-libs postgresql93-contrib postgresql93-devel Source: An almost idiot's guide to install PostgreSQL 9.3, PostGIS 2.1 and pgRouting with Yum share|improve find this I actually installed PostgreSQL 9.1 through the Ubuntu software center, but then built GDAL, GEOS, and PostGIS from source. Reload to refresh your session. Browse other questions tagged postgis postgresql installation ubuntu or ask your own question.

Can I use that to take out what he owes me? http://haywirerobotics.com/configure-error/configure-error-cannot-find-libzzip.html Install The simplest way of installing your new shiny PHP 5.2 now is:sudo make install Alternatively, if you plan to repeat the same installation again on other machines, or just want What is the total sum of the cardinalities of all subsets of a set? About Forums cPanel CloudLinux scripts Web Server Apache Nginx .htaccess WordPress Sitemap Errors 39 20+ common PHP compilation errors and fix - Unix by Arunlal Ashok · March 10, 2014 Compiling

asked 3 years ago viewed 3615 times active 3 years ago Get the weekly newsletter! I spent half an hour going through things that did not work and finally found this buried down here. :D –Peter Brown Nov 1 '13 at 21:45 1 This worked share|improve this answer answered Aug 15 at 2:14 Abe Petrillo 1,4831028 add a comment| Your Answer draft saved draft discarded Sign up or log in Sign up using Google Sign http://haywirerobotics.com/configure-error/configure-error-cannot-find-qt.html Web Sites: Disneyland vs Disney World in the United States Dishwasher Hose Clamps won't open What crime would be illegal to uncover in medieval Europe?

share|improve this answer edited Oct 21 at 17:09 Peter Mortensen 10.3k1370107 answered Jan 16 '12 at 23:34 Michael Durrant 46.8k46188299 3 Right, the Ruby pg gem wraps the usual PostgreSQL Provided configuration options: --with-opt-dir --without-opt-dir --with-opt-include --without-opt-include=${opt-dir}/include --with-opt-lib --without-opt-lib=${opt-dir}/lib --with-make-prog --without-make-prog --srcdir=. --curdir --ruby=/usr/bin/ruby1.8 --with-pg --without-pg --with-pg-dir --without-pg-dir --with-pg-include --without-pg-include=${pg-dir}/include --with-pg-lib --without-pg-lib=${pg-dir}/lib --with-pg-config --without-pg-config --with-pg_config --without-pg_config mkmf.log find_executable: checking for pg_config... Thanks Ari.

NOTE: the above-linked webpage includes a section 2.2 ("Requirements") which lists eight required software packages: PostgreSQL 8.4 GNU C compiler (gcc) GNU Make (gmake or make) Proj4 reprojection library, version 4.6.0

How difficult is it to practically detect a forgery in a cryptosystem? Is the result of the general election final on 8th of Nov, 2016? Then, look for the missing header using: apt-file search libpq-fe.h On my machine, this gives: libpq-dev: /usr/include/postgresql/libpq-fe.h postgres-xc-server-dev: /usr/include/postgres-xc/server/gtm/libpq-fe.h There you go ! Why does the size of this std::string change, when characters are changed?

Default value for date field How much time would it take for a planet scale Miller-Urey experiment to generate intelligent life Is it anti-pattern if a class property creates and returns How to migrate all cPanel accounts without its home directory? Why does the Minus World exist? http://haywirerobotics.com/configure-error/configure-error-cannot-find-pcap-h.html So try installing libpq-dev or its equivalent for your OS: For Ubuntu systems: sudo apt-get install libpq-dev On Red Hat Linux (RHEL) systems: yum install postgresql-devel For Mac Homebrew: brew install

In other news Parc Zoologique de Thoiry No need to go to Africa or Asia for a great safari experience - just 50 km west of Paris is completely enough. share|improve this answer answered Jun 22 '13 at 11:34 Javid Dadashkarimi 695 add a comment| up vote 0 down vote This worked for me: sudo gem install pg -- --with-pg-config=/Applications/Postgres.app/Contents/Versions/9.4/bin/pg_config share|improve How portable/common is this? I followed the instructions for installing PostGIS on this webpage: http://postgis.net/docs/manual-2.0/postgis_installation.html Section 2.4.1 ("Configuration") on this webpage tells me to type "./configure".

In it, you'll get: The week's top questions and answers Important community announcements Questions that need answers see an example newsletter Visit Chat Linked 2 Migrating to the use of databases asked 5 years ago viewed 164400 times active 17 days ago Upcoming Events 2016 Community Moderator Election ends Nov 22 Visit Chat Linked 3 Error Compiling Postgres pg gem on Ubuntu I found the problem is in the libpq-dev, how could I install/fix that? share|improve this answer edited Oct 21 at 17:18 Peter Mortensen 10.3k1370107 answered Oct 20 '14 at 16:21 Cynthia Sanchez 1195 add a comment| up vote 2 down vote On FreeBSD (9.1)

Please reinstall libmcrypt.