Home > Configure Error > Configure Error Cannot Find Ltdl.h

Configure Error Cannot Find Ltdl.h

See the Links below for more Help and those much wanted extras ... :) Read This First Fedora 10 & 9 Installation Script and Guide The easyLife Installation RPM MJMwired Fedora yes checking whether to enable maintainer-specific portions of Makefiles... They should >> > point you in the right direction. >> >> Well, I'm afraid I'm going to look thick, but I found little in >> config.log of interest except maybe in italics below I tried to add that option siince that is where I have a copy of the file it's after. Source

Pekny, mily a usmievavy webhosting a serverhousing: http://www.nic.sk/ -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.4.11 (GNU/Linux) Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/ iF4EAREIAAYFAlFZgVgACgkQLciChbMyGVROdgD/SlODfTnYTDRJOMrY07cRZ4mh Y9l0qCQCPIbCWq3DH0wA/2gOKCR5vqV0Yo4lvIal8k+n5VmISg6YJa3HETPef7ZF =b5bm -----END PGP SIGNATURE----- Re: [Courier-imap] Trouble One advantage of the convenience library is that it is not installed, so the fact that you use libltdl will not be apparent to the user, and it won’t overwrite a As it happens, it was in /usr/local/include, but I put a copy in /usr/include and I got exactly the same result... Please install Libtool's ltdl >> >> library >> >> >> >> But libltdl is indeed installed (from the port). >> >> >> >> I tried installing from packages but they can't http://www.linuxquestions.org/questions/linux-newbie-8/make-file-cant-find-a-ltdl-h-file-698884/

Please install Libtool's ltdl > >> library > >> > >> But libltdl is indeed installed (from the port). > >> > >> I tried installing from packages but they can't It almost looks like you can't even compile anything, manually. In such cases, you must decide what flavor of libltdl you want to use: a convenience library or an installable libtool library.

  1. By joining our community you will have the ability to post topics, receive our newsletter, use the advanced search, subscribe to threads and access many other special features.
  2. I'll ask around the traps here, but if it's obvious to you let me know, Cheers.
  3. Homebrew member MikeMcQuaid commented Aug 11, 2012 It's in the 10.7 SDK but I guess not in the 10.8 one. 2bits commented Aug 11, 2012 It's weird because I could build
  4. If it is installed in a non-standard *** location, please supply --with-ltdl=DIR on the configure command line, *** where `DIR' is the prefix where ltdl is installed (such as /usr, ***

Totally clueless on how to proceed next. More to do with the /home/eberwick/BO_3_1/bobje/mysql/include/my_global.h:361:24: error: asm/atomic.h: No such file or directory see appended Thanks for hanging in there lads and reading these posts, fair play to you. [[email protected] mysql-connector-odbc-3.51.27r695]# LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie make file can't find a "ltdl.h" file User Name Remember Me? You are sure you have installed both the kernel source and the headers for the kernel you're running?

You will need to set your configuration up carefully to make this work properly, and you will need releases of Autoconf and Automake that support subdir-objects and LIBOBJDIR properly. checking for suffix of object files... Signed-off-by: Jack Nagel 458eeb1 xu-cheng locked and limited conversation to collaborators Feb 16, 2016 Sign up for free to subscribe to this conversation on GitHub. configure:12769: checking for courier-config configure:12802: result: no configure:12812: checking for ltdl.h configure:12812: result: no configure:12816: error: Unable to find ltdl.h.

Since the program you're compiling is looking for atomic.h in an asm folder, then find the one that matches your kernel and that should be it. It's interesting you can't reproduce this. If you're not sure then at a terminal type Code: uname -a You should see one of your atomic.h files as a subfolder containing this kernel name. Please install Libtool's ltdl library But libltdl is indeed installed (from the port).

I found that I was missing libxslt. Homebrew member MikeMcQuaid commented Aug 8, 2012 Great. no >> configure: error: Cannot find ltdl.h -- libtool-devel not installed? >> >>> >> >> While there isn't a port or package that I can find called >> "libtool-devel", google suggests They should > > point you in the right direction. > > Well, I'm afraid I'm going to look thick, but I found little in > config.log of interest except maybe

gcc -DHAVE_CONFIG_H -I. -I. -I. -DNONTHREADSAFE -I/home/eberwick/BO_3_1/unixodbc/unixODBC-2.2.14/libltdl/include -I/usr/include -O3 -DDBUG_OFF -I/home/eberwick/BO_3_1/bobje/mysql/include -mcpu=pentiumpro -g -O2 -MT libmyodbc3_la-catalog.lo -MD -MP -MF .deps/libmyodbc3_la-catalog.Tpo -c catalog.c -fPIC -DPIC -o .libs/libmyodbc3_la-catalog.o `-mcpu=' is deprecated. http://haywirerobotics.com/configure-error/configure-error-cannot-find-pcap-h.html The time now is 11:24 AM. On my system, for example, atomic.h is found here: /usr/src/linux-headers-2.6.26-1-common/include/asm-x86/atomic.h but maybe naming conventions are very different between our two distros (CentOS and Debian). But that option only applies to the command line app and another option needs to be thrown otherwise configure will error on ML when it can't find `libltdl`.

There's a big disconnect somewhere, much more than just a file being out of place. Terms Privacy Security Status Help You can't perform that action at this time. If that doesn't work, check config.log. http://haywirerobotics.com/configure-error/configure-error-cannot-find-qt.html If LTDL_INIT can’t find them by itself, the person who builds your package can use this option to tell configure where the installed libltdl headers are. --with-ltdl-lib installed-ltdl-library-dir Similarly, the person

cheers, Ed [[email protected] mysql-connector-odbc-3.51.27r695]# make --include-dir=/usr/share/libtool/libltdl Making all in util make[1]: Entering directory `/tmp/mysql-connector-odbc-3.51.27r695/util' if /bin/sh ../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../driver -I/usr/include -O3 -DDBUG_OFF -I/home/eberwick/BO_3_1/bobje/mysql/include -mcpu=pentiumpro -g -O2 In order to use the convenience variant, just replace the LTDL_INIT option ‘installable’ with ‘convenience’. I mean, it's sort of expected that it fails since that specific option has been removed from the configure options. 2bits commented Aug 8, 2012 I lost this thread because of

Please visit this page to clear all LQ-related cookies.

The problem with auto[conf|make|headers] and aclocal were resolved by installing the gnu- versions of those programs, as the FreeBSD ports tree versions are more prone to causing problems with compiles taking Please install Libtool's ltdl library . . . You seem to have CSS turned off. yes checking ltdl.h usability...

In your configure.ac, add: AM_INIT_AUTOMAKE([subdir-objects]) AC_CONFIG_HEADERS([config.h]) LT_CONFIG_LTDL_DIR([libltdl]) LT_INIT([dlopen]) LTDL_INIT([nonrecursive]) You have to use a config header, but it may have a name different than config.h. Registration is quick, simple and absolutely free. I tried with several directories witch I took from 'locate ltdl' But I get always the same error. *** This is what I'v found in the log file: configure:25327: checking for Check This Out If you are using Autoconf and Automake, then you will need to add the following to your configure.ac: LT_CONFIG_LTDL_DIR([libltdl]) LTDL_INIT and to Makefile.am: SUBDIRS = libltdl Aside from setting the libltdl

All Rights Reserved. In file included from ../MYODBC_MYSQL.h:12, from myodbc3.h:37, from catalog.c:44: /home/eberwick/BO_3_1/bobje/mysql/include/my_global.h:361:24: error: asm/atomic.h: No such file or directory make[2]: *** [libmyodbc3_la-catalog.lo] Error 1 make[2]: Leaving directory `/tmp/mysql-connector-odbc-3.51.27r695/driver' make[1]: *** [all] Error 2 This keyword will cause options to be passed to the configure script in the subdirectory named by LT_CONFIG_LTDL_DIR to cause it to be built as a convenience library. Already have an account?

If it is not in the man pages or the how-to's this is the place! Add a configure flag to `--disable-crypto-dl` Fixes #13845">libxmlsec1: fix configure error on ML … libxmlsec1 already has an option thrown on the command line to `disable-apps-crypte-dl` which stops the build from Agrouf knows a lot more than me, so I'd certainly follow his/her suggestion. To use Google Groups Discussions, please enable JavaScript in your browser settings, and then refresh this page. .

Are you new to LinuxQuestions.org? Main Menu LQ Calendar LQ Rules LQ Sitemap Site FAQ View New Posts View Latest Posts Zero Reply Threads LQ Wiki Most Wanted Jeremy's Blog Report LQ Bug Syndicate Latest Agrouf View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by Agrouf 01-22-2009, 06:34 AM #6 nedzer Member Registered: Dec 2008 Posts: 44 Footnotes (12) We used to recommend adding the contents of ltdl.m4 to acinclude.m4, but with aclocal from a modern Automake (1.8 or newer) and this release of libltdl that is not

Personal Open source Business Explore Sign up Sign in Pricing Blog Support Search GitHub This repository Watch 1,053 Star 29,483 Fork 14,002 Homebrew/legacy-homebrew Code Issues 1 Pull requests 0 Projects I had to brew install libxslt and brew link libxslt snakeyroc3 pushed a commit to snakeyroc3/homebrew that referenced this issue Dec 17, 2012 nibbles 2bits