Home > Configure Error > Configure Error Cannot Find Usable Expat Library

Configure Error Cannot Find Usable Expat Library

no checking for mawk... yes checking for XML_SetDoctypeDeclHandler... comment:2 Changed 7 years ago by jmroot (Joshua Root) Component changed from base to ports Description modified (diff) Port fontconfig added Note: See TracTickets for help on using tickets. yes checking for expat.h... Source

nochecking expat.h usability... The configure script always stumbles upon the same error message. yes checking for link... Optimised for standards. https://lists.freedesktop.org/archives/fontconfig/2005-March/001289.html

no checking for nawk... yes checking for FT_Bitmap_Size.y_ppem... yes checking for FT_Get_BDF_Property... Log on to http://in.promos.yahoo.com/rakhi/index.html Follow-Ups: Re: Compiling pkgconfig with arm-linux-gcc From: ibr References: Re: Compiling pkgconfig with arm-linux-gcc From: ibr [Date Prev][Date Next] [Thread Prev][Thread Next] [Thread Index] [Date

configure: error: Package requirements (libxml-2.0 >= 2.6) were not met: No package 'libxml-2.0' found Consider adjusting the PKG_CONFIG_PATH environment variable if you installed software in a non-standard prefix. See the pkg-config man page for more details. yes checking for mkstemp... yes checking XML_SetDoctypeDeclHandler...

yes checking for FT_Get_X11_Font_Format... yes checking for expat.h... I searched for libxml and installed libxml2: horus:~ root# port search libxml p5-libxml-enno perl/p5-libxml-enno 1.02 libxml-enno contains the modules XML::DOM, XML::XQL, XML::Checker and several other packages that are no longer distributed no checking for geteuid...

Top Mihael Souza Rank: Padawan Posts: 65 Join Date: 10/11/12 Recent Posts RE: configure: error: Compiler can't find Answer (Unmark) 5/16/14 12:47 PMas a reply to Adri Mourits. yes checking for strtol... I've started a patch that does this; my current patch is available at http://plam.csail.mit.edu/~plam/tmp/fontconfig-strings-to-indices.diff I'm also willing to replace FcPatternIndex with a void * datatype that would be cast to ints Whenever I run./configure, the script stops with the following errormessage:configure: error: Cannot find usable expat library.This could mean that your version is too old.Since my first attempt, I already had expat-1.95.8installed,

  1. In that case > you probably need a global refcount for all patterns in the mmaped file, so > you know when nothing references the old cache file anymore.
  2. storm, surge and algal bloom forecasting.   On this discussion page you can post questions, research discussions or just share your experience about modelling coastal and/or estuarine systems with Delft3D FM.
  3. Just in case I tried some older versions of expat too, but as I said before, the result was the same.
  4. I already did some googling too, but couldn'tfind an useful answer.These are the last few lines the configure scriptgenerates before stopping:checking for FT_Bitmap_Size.y_ppem...
  5. p5-libxml-perl perl/p5-libxml-perl 0.08 Collection of Perl modules for working with XML.
  6. Attachments: configure.log.txt (10.0k) Sign in to vote.
  7. yes checking for pid_t...
  8. perhaps the solution would be editing the ./configure script? __________________________________________________ Do You Yahoo!?
  9. yes checking expat.h usability...

no configure: error: Cannot find usable expat library. http://osdir.com/ml/fonts.fontconfig/2005-03/msg00057.html yes checking for getuid... Just in case I tried some older versions of expat too, but as I said before, the result was the same. Flag Please sign in to flag this as inappropriate.

yeschecking expat.h presence... this contact form yes checking for gawk... If anyopne knows something please help us out. Whenever I run ./configure, the script stops with the following error message: configure: error: Cannot find usable expat library.

Shame on me forforgetting to look for a solution in "./configure-help", the answer was right there...Adrian.Post by Keith PackardPost by Adrian CarmackI run the configure with the--with-expat-lib=/usr/local/include parameter,elsePost by Adrian Carmackthe This could mean that your version is too old. Since my first attempt, I already had expat-1.95.8 installed, built from source. have a peek here Small Business - Try our new resources site!http://smallbusiness.yahoo.com/resources/ 2 Replies 18 Views Switch to linear view Disable enhanced parsing Permalink to this page Thread Navigation Adrian Carmack 2005-11-21 08:51:05 UTC Keith

Top GNOME.org Home Mailing Lists List Archives Search Re: Compiling pkgconfig with arm-linux-gcc From: prakhar vig To: ibr ata cs hun edu tr Cc: gtk-list gnome no checking xmlparse.h presence... Yahoo!

no checking expat.h usability...

no checking expat.h usability... Mail has the best spam protection around http://mail.yahoo.com Previous message: [Fontconfig] Gtk+/Fontconfig/Pango.....Config error? I fear that applications will hold FcFontList results for lengthy periods though, essentially locking down old cache files forever. Estuaries generally have one or more branching channels, intertidal mudflats and/or salt marshes.

These are the last few lines the configure script generates before stopping: checking for FT_Bitmap_Size.y_ppem... This could mean that your version is too old. Hosted by Red Hat. http://haywirerobotics.com/configure-error/configure-error-cannot-link-with-the-boost-thread-library.html no configure: error: Cannot find usable expat library.

Intertidal areas are of high ecological importance and trap sediments (sands, silts, clays and organic matter). no checking expat.h presence... Tired of spam? yes checking for FT_Bitmap_Size.y_ppem...

Regards,Mihael Souza Sign in to vote. We need a better listing API in any case, to permit faster matching, so perhaps we can fix both problems at the same time. -keith pgpnePRVTU2pW.pgp Description: PGP signature _______________________________________________ fontconfig yes checking for memmove... Suspecting some kind of version incompatibility, I've tried quite a few combinations of current and older versions of both fontconfig and expat, tried removing expat, and install the older 1.95.6 version

Powered by MailMan fontconfig 2.4.2 compile woes Sebastiaan Couwenberg sebastic at xs4all.nl Sun Oct 21 17:27:29 CEST 2007 Previous message: port name unification for libraries Next message: fontconfig 2.4.2 compile woes yeschecking for struct shm_info... comment:7 Changed 7 years ago by ryandesign (Ryan Schmidt) Resolution set to invalid Status changed from new to closed Note: See TracTickets for help on using tickets. perhaps the solution would be editing the ./configure script? __________________________________________________ Do You Yahoo!?

Could someone please help me get over this problem... Step to configure expat: ./configure --host=arm-linux. checking for pkg-config... /opt/local/bin/pkg-config checking pkg-config is at least version 0.9.0... yes checking for getopt...

no checking for xmlparse.h... Can someone offer some help?- Thanks. nochecking expat.h usability...