Home > Configure Error > Configure: Error: Freetype-config Not Found.

Configure: Error: Freetype-config Not Found.

Contents

Maybe you could add those solutions onto your tutorial. (2 symbolic links created and two packages installed made me get by this). Pre-requisites Make sure all the build tools are installed and ready: patch, gcc, glibc, libstdc++, gcc-c++, binutils, libtool, autoconf, make CentOS: yum install patch gcc glibc libstdc++ gcc-c++ binutils libtool autoconf Check config.log for additional information. Please reinstall it. Source

Fix: Install 'patch' program CentOS: yum install patch CentOS(64bit): yum install patch.x86_64 Ubuntu: apt-get install patch Error Message: Can not make Cause: Program 'make' is missing on the building server. For all you Drupallers out there - you successfully managed to change this: into this: Well done! Any idea's how to solve this / find these files? Accessing PhpMyAdmin without cPanel login? http://www.lifelinux.com/error-compiling-php-on-centos-x64/

Configure: Error: Freetype-config Not Found.

That means you can customize your own PHP with custom modules. Reply Usman Nasir says: August 23, 2016 at 7:25 pm Really saved a lot of trouble.. Configure: error: Please reinstall the BZip2 distribution #yum install bzip2-devel 2.

Fix: # yum install db4-devel 1 # yum install db4-devel Для тех кто хочет быстро исправить все проблемы, попробуйте запустить так: # yum install glibc-utils.x86_64 libtool-ltdl-devel.x86_64 libxslt.x86_64 libxslt-devel.x86_64 libtidy.x86_64 libtidy-devel.x86_64 aspell-devel.x86_64 bzip2-devel.x86_64 php-mysql.x86_64 The ‘links' package is required for this functionality. # yum search links # yum install elinks 17. Required fields are marked *Comment Name * Email * Website Current [emailprotected] * Leave this field empty Follow: CategoriesCategories Select Category Administrative tools CloudLinux commands exim MySql Control panels cPanel Direct Configure: Error: Xslt-config Not Found. Please Reinstall The Libxslt >= 1.1.0 Distribution Check your SNMP installation.

Please reinstall the libxslt >= 1.1.0 distribution # yum install libxslt-devel >>>> fixed 8. Configure: Error: Jpeglib.h Not Found. This should not happen. Procedures 1. https://coderwall.com/p/ggmpfa/php-configuration-error-and-solutions-in-rpm Then, rerun this script.

yes, shared not found configure: error: pcre.h not found Cause: configure with '--with-pcre=shared,/usr' but pcre-devel(.x86_64) package is missing Fix: CentOS: yum install pcre-devel CentOS(64bit): yum install pcre-devel.x86_64 Ubuntu: apt-get install libpcre3-dev Configure: Error: Your T1lib Distribution Is Not Installed Correctly. Please Reinstall It. If you do not find an answer here, you are free to “google” your error message for solutions. Let's then download and uncompress PHP sources into ~/Downloads/php-5.2.17 directory: mkdir -p ~/Downloads/php-5.2.17
cd ~/Downloads/php-5.2.17
wget http://museum.php.net/php5/php-5.2.17.tar.gz
tar
zxf php-5.2.17.tar.gz Configure Time to configure the package. HelloWorld Community Any senior Drupal devs out there interested in working in/moving to Vietnam, or Switzerland, or Netherlands?

  1. Solution: yum install net-snmp-devel ERROR XV : checking whether to enable XMLWriter support… yes, shared checking for xml2-config path… (cached) /usr/bin/xml2-config checking whether libxml build works… (cached) yes checking for XSL
  2. Solution: yum install libmcrypt-devel.x86_64 ERROR XXII : configure: error: Cannot find libtidy Solution: yum install libtidy libtidy-devel That's it 🙂 Arunlal Ashok Linux Server Administrator.
  3. Please reinstall the libxslt >= 1.1.0 distribution Cause: configure with '--with-xsl=shared,/usr' but libxslt-devel(.x86_64) package is missing Fix: CentOS: yum install libxslt-devel CentOS(64bit): yum install libxslt-devel.x86_64 Ubuntu: apt-get install libxslt-dev Error Message:
  4. It really helped me in fixing compilation errors..
  5. And most probably will.
  6. I am glad to know this article is helpful to you. 🙂 Reply koosah says: August 13, 2014 at 7:58 am Say + average of 5 mins for 19 yum installations
  7. One way of doing it is using mod_php5 Apache module to serve PHP 5.3 applications, while running PHP 5.2 applications using fastcgi module.
  8. I started this blog to share and discuss my ideas with the world.
  9. ext/zip/lib/.libs/zip_dirent.o: In function `memset': /usr/include/x86_64-linux-gnu/bits/string3.h:82: warning: memset used with constant zero length parameter; this could be due to transposed parameters Finally PHP bug #53568, with a pretty easy fix: edit file

Configure: Error: Jpeglib.h Not Found.

make install1make installNow lets execute php -v and to confirm the we are indeed running php 7. you can try this out Fix: CentOS: yum install bzip2-devel CentOS(64bit): yum install bzip2-devel.x86_64 Ubuntu: apt-get install libbz2-dev Error Message: checking for cURL support... Configure: Error: Freetype-config Not Found. Configure: error: Unable to locate gmp.h # yum install gmp-devel 15. Configure: Error: Png.h Not Found. You may need EPEL repository to get them all installed CentOS 6: yum install libxml2-devel openssl-devel bzip2-devel libcurl-devel db4-devel libjpeg-devel libpng-devel libXpm-devel \ freetype-devel gmp-devel libc-client-devel openldap-devel libmcrypt-devel mhash-devel freetds-devel \

Please reinstall the libxslt >= 1.1.0 distribution Solution: yum install libxslt-devel ERROR XVI : configure: error: xml2-config not found. this contact form there always is next year! Reply junghoonYu says: October 29, 2015 at 4:59 am thanks.. –with-unixODBC=/usr Reply PERI VENKATA RAMANA says: July 29, 2014 at 6:22 pm Super .. Let's go through some of the possible errors then (you can skip to the next section if your ./configure finished without any errors and displayed nice Thank you for using PHP Configure: Error: Mcrypt.h Not Found. Please Reinstall Libmcrypt.

In most cases quite a lot of dependencies will be missing. Configure: error: Did not find pcre-config script at /usr/local #yum -y install pcre-devel 19. invalid
configure: WARNING: This bison version is not supported for regeneration of the Zend/PHP parsers (found: none, min: 204, excluded: ).
checking for re2c... http://haywirerobotics.com/configure-error/configure-error-cannot-run-bin-sh-support-config-sub.html Home About RSS/FEED Error compiling PHP on CentOS x64 by lifeLinux on April 19, 2011 configure: error: xml2-config not found.

Tomáš Votruba Very nice article! Configure: Error: Xpm.h Not Found. yum install freetype-devel.x86_64 configure: error: Please reinstall the iconv library. "--with-iconv" \ configure: error: mcrypt.h not found. Can't figure out your VCS, not cleaning.

Congrats!

Please check your net-snmp installation. # yum install net-snmp-devel Reply faina09 says: September 24, 2015 at 10:59 am configure: error: Can not find recode.h # yum install recode-devel -y Reply Firas Pingvis Running .configure fails with error: Unable to locate gmp.h. ext/gmp/gmp.c: In function ‘zif_gmp_random’: ext/gmp/gmp.c:1399:69: error: ‘__GMP_BITS_PER_MP_LIMB’ undeclared (first use in this function) ext/gmp/gmp.c:1399:69: note: each undeclared identifier is reported only once for each function it appears in This time it's Configure: Error: Utf8_mime2text() Has New Signature, But U8t_canonical Is Missing Almost there!

RT @dwkitchen: On my bike for #CycleToWorkDay http://t.co/OTyjUVifKJ 4 Sep '14 via Twitter Oh. By using package manager the dependencies are automatically detected and install with the corresponding package. You either need to build pdo_sqlite shared or build pdo statically for the build to be successful. Check This Out Therefore developing for both D7 and D6 at the same time becomes much less painful when running both versions of PHP in parallel.

Configure: error: DBA: Could not find necessary header file(s). # yum install gdbm-devel # yum install db4-devel 3. Configure: error: libpng.(a|so) not found. # yum install libpng-devel 5. Now tempted by http://t.co/h0UrWcRUjV 20 Aug '14 via Twitter Damn. Fix: Install 'autoconf' program.

no
configure: WARNING: You will need re2c 0.13.4 or later if you want to regenerate PHP parsers.
configure: error: bison is required to build PHP/Zend when building a GIT yes configure: error: Please reinstall libedit - I cannot find readline.h Cause: configure with '--with-libedit', however, libedit-devel package is missing Fix: CentOS: yum install libedit-devel CentOS64: yum install libedit-devel.x86_64 Ubuntu: apt-get yes, shared configure: error: xslt-config not found. Fix: Install 'make' program CentOS: yum install make CentOS(64bit): yum install make.x86_64 Ubuntu: apt-get install make Error Message: Could not find xml2-config Cause: configure option '--with-libxml-dir=/usr' used BUT package libxml2-devel is

Do not attempt to compile or install php7 on a production machine, you have been warned. yes, shared configure: error: mcrypt.h not found. no checking for cURL in default path... no configure: error: SNMP sanity check failed.

You saved 2 hours of many many people including me 😀 Reply Vikash Dhiman says: September 26, 2014 at 3:49 pm What a lovely article. Please check your libxml2 installation. Make sure your ubuntu machine has at least 1GB of RAM before proceeding. Is it installed?

To avoid this, install autoconf-2.13. Download PHP sources Let's then start with downloading PHP 5.2 sources from Unsupported Historical Releases list. sudo apt-get install libxpm-dev configure: error: freetype.h not found. Fix: yum install mysql-devel Reply Leo says: November 3, 2014 at 8:57 am configure: error: snmp.h not found.

Please specify correct PostgreSQL installation path Cause: configure with '--with-pdo-pgsql=shared,/usr' but postgresql-devel(.x86_64) package is missing Fix: CentOS: yum install postgresql-devel CentOS(64bit): yum install postgresql-devel.x86_64 Ubuntu: apt-get install postgresql-server-dev-8.3 (aptitude search postgresql Fix: Install 'libxml2-devel' package CentOS: yum install libxml2-devel CentOS(64bit): yum install libxml2-devel.x86_64 Ubuntu: apt-get install libxml2-devel Error Message: Could not find evp.h Cause: configure option '--with-openssl' used BUT package openssl-devel(.x86_64) is