Home > Emacs Cannot > Emacs Cannot Open Termcap

Emacs Cannot Open Termcap

Why don't you use the one in the archive? That's no proof: a man page can exist without the binary, and viceversa. You can not post a blank message. You can use the terminfo utilities (tic, infotocap, toe, captoinfo, infocmp, ...) to convert the most needed terminfo entries to termcap format and store it in some private dot file, $HOME/.termcap http://haywirerobotics.com/emacs-cannot/emacs-cannot-open-termcap-database.html

I want to determine whether it is missing altogether, or is there but is inaccessible to Emacs for some reason. The time now is 01:26 PM. They hope these examples will help you to get a better understanding of the Linux system and that you feel encouraged to try out things on your own. The Emacs that comes with OS X starts up, but it is version 22, but I installed the MacPorts port of Emacs because I needed version 23. https://lists.gnu.org/archive/html/help-gnu-emacs/2005-07/msg00529.html

Registration is quick, simple and absolutely free. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.  Apple Support Communities More ways to shop: Visit an Apple Instead, please use "type" builtin: "type emacs" etc. User contributions on this site are licensed under the Creative Commons Attribution Share Alike 4.0 International License.

  1. So, this did not show up.Removing the above alias from my .bash_profile fixed the problem.I hope this helps someone.
  2. I have many other options, including the Cocoa native GUI version of Emacs.
  3. Set the environment variable TERMCAP to have the full path of the termtype database file.
  4. All rights reserved.
  5. But a couple of things can mess this up, for example if the TERMINFO environment variable exists and is pointing to somewhere other than a terminfo database or if the TERM
  6. Results 1 to 2 of 2 Thread: compile emacs from source code but can't open termcap database file Thread Tools Show Printable Version Subscribe to this Thread… Display Linear Mode Switch
  7. Can variation ratio ever be 0?
  8. Under 10.5.8, Emacs in a terminal window worked fine, but after upgrading, it appears to be broken:% which emacs/usr/bin/emacs% emacs -versionGNU Emacs 23.1.50.1...% emacsemacs: Cannot open termcap database fileAny ideas?
  9. For the yum-challenged (non-root users…), do the following: Download a proper termcap database from http://catb.org/terminfo/ [TermType database] (it'll be called termtypes.tc.gz when gzipped, and termtypes.tc after being extracted with gunzip).
  10. Nov 16, 2009 6:28 PM Helpful (0) Reply options Link to this post by Jun T., Jun T.

Thanks very much in advance. United States Copyright © Apple Inc. Or does anyone know a better way to install emacs without root or a package manager? Date: Sat, 30 Jul 2005 20:31:23 +0200 Am 30.07.2005 um 19:48 schrieb Erik the Red: emacs is definitely installed because a man page comes up when I type "man emacs".

What's up with that? First attempt: I tried doing it from the tarball but I get an error that tputs was not provided by any of the usual packages, e.g. Operator ASCII art Draw a hollow square of # with given width Antonym for Nourish Total distance traveled when visiting all rational numbers Why does the size of this std::string change, check over here Try installing Build-Depends by running sudo apt-get build-dep emacs22 Adv Reply Quick Navigation Packaging and Compiling Programs Top Site Areas Settings Private Messages Subscriptions Who's Online Search Forums Forums Home

conda install -c https://conda.anaconda.org/alorenzo175 emacs This complains: emacs: Cannot open terminfo database file But: $ whereis terminfo terminfo: /etc/terminfo /lib/terminfo /usr/share/terminfo /usr/share/man/man5/terminfo.5.gz Do I need to compile with some settings to Hot Network Questions Is adding the ‘tbl’ prefix to table names really a problem? Please visit this page to clear all LQ-related cookies. And that looks up information in the terminfo database (a set of files), which may be at /usr/share/terminfo/..whatever...

Erik_the_Red Linux - Software 4 07-31-2005 11:21 AM emacs: Cannot open termcap database file severedhead Linux - General 0 08-20-2002 04:15 PM emacs: Cannot open termcap database file severedhead Linux - This book contains many real life examples derived from the author's experience as a Linux system and network administrator, trainer and consultant. Level 6 (19,885 points) Mac OS X Nov 16, 2009 9:55 AM in response to Jun T. 22.1.1 is what I get on my Leopard (10.5.8) system. This discussion is locked            Gary Schiltz Level 1 (0 points) Q: Emacs in 10.6.2 Terminal I recently upgraded from Leopard to Snow Leopard.

Then compile Emacs again and everything should work normally with it as the default editor in your server. http://haywirerobotics.com/emacs-cannot/emacs-cannot-open-termcap-database-file-centos.html I hope nobody wastes any more time digging into this.Just for grins, I will post for the record a couple of observations:For some reason, I also have an emacs-i386 file, but The first thing to figure out is where is Emacs looking for this termcap file? reply via email to [Prev in Thread] Current Thread [Next in Thread] "Cannot open termcap database file", kj<= Re: "Cannot open termcap database file", despen, 2010/12/19 Re: "Cannot open termcap database

Index(es): Date Thread help-gnu-emacs [Top][All Lists] Advanced [Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] "Cannot open termcap database file" From: kj Subject: "Cannot open termcap database file" Date: Sat, 18 Dec Do you want to help us debug the posting issues ? < is the place to report it, thanks ! Thanks! ~kj P.S. his comment is here Google is your friend here.Apple is not really into the traditional text editors, so they tend to leave a lot of the good stuff out.

Alternative, is there a way to circumvent this requirement? Your response does show me that something is messed up with my system. See what stuff is missing in the generated configure.log.

Nov 16, 2009 7:49 AM in response to Gary Schiltz Level 4 (2,185 points) Nov 16, 2009 7:49 AM in response to Gary Schiltz I'm not an emacs user, but on

I may have upgraded my Emacs at one point under 10.5.x, and those updates got only partially propagated when I upgraded to 10.6. Are you sure maybe your version did not get updated? Check these? Your Answer draft saved draft discarded Sign up or log in Sign up using Google Sign up using Facebook Sign up using Email and Password Post as a guest Name

Ubuntu Ubuntu Insights Planet Ubuntu Activity Page Please read before SSO login Advanced Search Forum The Ubuntu Forum Community Ubuntu Specialised Support Development & Programming Packaging and Compiling Programs compile emacs This file might be to old, not knowing your modern terminal emulation. more hot questions question feed about us tour help blog chat data legal privacy policy work here advertising info mobile contact us feedback Technology Life / Arts Culture / Recreation Science weblink What movie is this?

For the most part, I'm a vim user myself, but I've been trying to "broaden my horizons" and learn Emacs. Join our community today! Nov 16, 2009 5:59 PM Helpful (0) Reply options Link to this post by Gary Schiltz, Gary Schiltz Nov 16, 2009 6:28 PM in response to Gary Schiltz Level 1 (0 Target: i486-linux-gnu Configured with: ../src/configure -v --enable-languages=c,c++,fortran,objc,obj-c++,treelang --prefix=/usr --enable-shared --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --enable-nls --with-gxx-include-dir=/usr/include/c++/4.1.3 --program-suffix=-4.1 --enable-__cxa_atexit --enable-clocale=gnu --enable-libstdcxx-debug --enable-mpfr --enable-checking=release i486-linux-gnu So miracle come!

The time now is 07:26 PM. I'm a linux newbie and admit there's probably something obvious I just don't see.I've read the termcap is obsolete and terminfo used in conjunction with ncurses is the proper way to emacs quick hacks Previous post Next post Comments Please enable JavaScript to view the comments powered by Disqus. Comments powered by Disqus © MMXV Jonas Gorauskas - Some Rights Reserved - all my opinions are belong to me Open Menu Close Menu Apple Shopping Bag Apple Mac iPad iPhone

Then when I went to run Emacs, I got the error Cannot open termcap database file. This was to install using the conda python installer. Can someone tell me what filenames and directories to search for this file? I did export TERMCAP=emacs.

Note that registered members see fewer ads, and ContentLink is completely disabled once you log in. In Doctor Strange what was the title of the book Stan Lee was reading in his cameo? Last edited by Dr_P_Ross; 11-16-2010 at 05:32 AM. Join Date Nov 2006 Location nanjing University of post and telecommunication Beans 58 DistroUbuntu 6.10 Edgy compile emacs from source code but can't open termcap database file emacs: Cannot open termcap

Windows Upgrade ActivationIssues? Can someone P-L-E-A-S-E point me in a direction that will help me sort out my termcap problem and get emacs up and running? Still, I proceed with make not knowing what else to do followed by make install.All seems to go again without incident until I attempt to invoke ./emacs which returns with "emacs: You may be interested to know that this is actually a common problem in a No X of Ubuntu Server.

This is free software; see the source for copying conditions. I went into Makefile.in and did #define LIBS_TERMCAP -lcurses and then did #define LIBS_TERMCAP -lncurses because it appears that I'm using new curses. If you are installing emacs on linux (redhat enterprise server, in my case) and are stuck on the error "emacs: Cannot open termcap database file", then read on! From: Peter Dyballa Subject: Re: Cannot open termcap database file for emacs?