Home > Error Cannot > Error Cannot Link With The Boost Thread Library

Error Cannot Link With The Boost Thread Library

How do you put this LIBS="~~~" to the command ./configure command line, or does it need to be in the configure files? I followed your suggestion and re-install boost 1.38 version. no checking whether pthreads work with -Kthread... Why does low frequency RFID have a short read range? his comment is here

If you needed to append -mt for the thread library, chances are you also need to append the same extension to the other as well. Homebrew member dunn commented Oct 27, 2015 I'm seeing the same error on El Capitan. Those tended to be less troublesome for us. I'm trying to install Tophat. http://askubuntu.com/questions/420100/pov-ray-installation-configure-error

Affecting: Gearman Filed here by: rohgeo When: 2012-05-15 Completed: 2012-11-01 Target Distribution Baltix BOSS Juju Charms Collection Elbuntu Guadalinex Guadalinex Edu Kiwi Linux nUbuntu PLD Linux Tilix tuXlab Ubuntu Ubuntu Linaro no > checking whether to build the boost thread library from sources... Sign in. i am freshman about linux.

  1. no checking whether pthreads work with -Kthread...
  2. no > checking for the pthreads library -lpthreads...
  3. I've uninstalled and reinstalled it using Homebrew since I started investigating this problem, but it did not report any problems during the installation.
  4. I'm not sure how to diagnose the problem further, whether it is a problem with where boost is located on my system, and ./configure can't find it properly, or whether it
  5. Post a reply to this message From: clipka Subject: Re: How to build boost to compile POVRay beta 32 Date: 14 May 2009 20:25:00 Message: "djconnel" wrote: > Wow
  6. you can contribute!
  7. Top Display posts from previous: All posts1 day7 days2 weeks1 month3 months6 months1 year Sort by AuthorPost timeSubject AscendingDescending Post Reply Print view 14 posts • Page 1 of 1 Return

Did you install the libboost-thread1.49-dev package ? > [extract of configure output to console:] > ... > Libraries > --------- > checking whether to link with cygwin DLL... Why there are no approximation algorithms for SAT and other decision problems? gcc and g++ are present on my system, installed via Homebrew, and the directory where they are located is in $PATH, but they are not being called by ./configure, and I yes Looks, -pthread is ok. (whereas -lpthreads is not :-), be happy of the gnu compiler ) > checking for joinable pthread attribute...

more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed Peter Valdemar Mørch (pmorch) wrote on 2015-02-12: #7 Make that LDFLAGS=-lboost_system to also let it pass 'make' also :-) I also needed apt-get install libpq-dev and CPPFLAGS="-I/usr/include/postgresql" here on Debian jessie, Wise Post a reply to this message From: DanConnelly Subject: Re: How to build boost to compile POVRay beta 32 Date: 13 May 2009 23:11:49 Message: <[email protected]> Any resolution on this? https://github.com/Homebrew/legacy-homebrew/issues/45317 Quote Postby Genete » Tue Apr 08, 2014 9:42 am Please notice what does bootstrap.h do:https://github.com/synfig/synfig/blob/m ...

yes > checking whether the boost thread library is usable... It seems checking for this would make a nice modification of the > configure script. .... j6thomps commented Oct 28, 2015 Hi c-lipka, I have tried including the line LIBS="-lboost_system -lboost_thread" when compiling povray from source, but the build fails when checking if the C compiler works, no checking for the pthreads library -lpthreads...

Web Sites: Disneyland vs Disney World in the United States Is adding the ‘tbl’ prefix to table names really a problem? http://news.povray.org/povray.unix/thread/%[email protected]%3E/ about • faq • rss Community Log In Sign Up Add New Post Question: tophat install problem 1 23 months ago by biolab • 810 China biolab • 810 wrote: Hi no > checking for the pthreads library -lpthreads... Seipas commented Feb 21, 2016 It seems to work, I was able to build and to render scenes/lights/arealit3.pov Thank you !

welcome aboard Please, could you had "Solved" in the initial post title ? this content headers and library files).og_da_trog wrote:then I created the build.sh file inside the synfig folder that was created when I cloned synfig from guthub.Code: Select all#!/bin/sh
cd synfig
CPUS=4
prefix=$(pwd)/install
export PKG_CONFIG_PATH="$prefix/lib/pkgconfig"
Thank you very much, > I can go ahead one step now. :) > But still have some issues. > > I followed your suggestion and re-install But I also have a Cent 5 (Redhat) system for which there's no boost package about 1.33.

I tried the --with-boost-thread=boost_thread-mt flag suggested on the download page, but it didn't help. no checking for the pthreads library -llthread... Slightly annoyed at myself that I didn't realize the problem was that simple. http://haywirerobotics.com/error-cannot/error-cannot-link-librrd.html Adding a soft link for libboost_system in the same directory was all I needed.  Was smooth sailing from there on out.

Thanks Changed in gearmand: importance: Undecided → Low Brian Aker (brianaker) on 2012-05-22 Changed in gearmand: status: New → Incomplete hansenn (zhoujian) wrote on 2012-05-22: #2 my sistem is Ubuntu 11.10. yes checking for joinable pthread attribute... Terms Privacy Security Status Help You can't perform that action at this time.

I am writing this, in case there's anyone who has the same problem as mine. ./configure COMPILED_BY="name " LIBS="-lboost_system -lboost_thread" This solved my problem, and here's some other solutions. [POV-Ray Newsgroup

This is on a Kubuntu > 13.04 64bit machine; I had previously installed 3.7RC6 on Kubuntu 12.10 and the > same hardware without significant difficulty. Usually you have to supply -L[/path/to/boost] somewhere in there so it knows where to find it. –Michael Kristofik Mar 5 '12 at 20:57 Recent versions of boost would require no > checking for the pthreads library -llthread... no > checking for exit in -lboost_thread-boost_thread...

nochecking for exit in -lboost_program_options... (cached) noconfigure: error: Could not link against boost_program_options !I tried doing:Code: Select all./configure --with-boost-libdir=/usr/lib/x86_64-linux-gnubut it still didnt workthankyou for your help c: Last edited by og_da_trog Contact GitHub API Training Shop Blog About © 2016 GitHub, Inc. PTHREAD_CREATE_JOINABLE checking if more special flags are required for pthreads... check over here Skip to content Ignore Learn more Please note that GitHub no longer supports old versions of Firefox.

otstrap.sh-G Synfig needs your help!Developers, packagers, bug testers, translators, artists, web developers, wiki writers... Sorry. Global.asax Application_Start not hit after upgrade to Sitecore 8.2 Is privacy compromised when sharing SHA-1 hashed URLs? Mark as duplicate Convert to a question Link a related branch Link to CVE Duplicates of this bug Bug #1019095 You are not directly subscribed to this bug's notifications.

Though it never occurred to me that other users might have the same trouble figuring this out - after all, if it isn't explicitly mentioned *anywhere*, it just *must* be trivial