Home > Error Cannot > Error Cannot Open /opt/freeware/packages/packages.rpm

Error Cannot Open /opt/freeware/packages/packages.rpm

What movie is this? David, I'd say it got me exactly what I wanted, and that is a leg up on these RPM issues in general, as well as in specific with aixtoolbox! Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.Just copy and paste the BBCode HTML Markdown MediaWiki reStructuredText code below into your site. IBM: AIX Forum Therefore, if you get the following error message ... 0509-150 Dependent module /opt/freeware/lib/libintl.a(libintl.so.8) could not be loaded. 0509-152 Member libintl.so.8 is not found in archive ... http://haywirerobotics.com/error-cannot/error-cannot-open-an-http-server-socket-error-reported-errno-eacces.html

Have you tried with rpm-4.2? The same is possible on Unix using ACLs, policies, security profiles, or just sudo (if installed), with a much higher granularity (eg. Why there are no approximation algorithms for SAT and other decision problems? Using the example from above you would have downloaded the file aaa.aix5.1.ppc.rpm and would then issue the following command: # either download with FTP protocol while read i; do wget ftp://www.oss4aix.org/everything/RPMS/${i} More hints

doesn't look that there is any other process running on the machine which is using the lock. You probably also want the kernel and glibc packages from Red Hat 9 which support NPTL used by rpm -> Berkeley DB for posix mutexes used to support concurrency. Requires: rpm >= 4.2 will take care of most of the problems. 73 de Jeff -- Jeff Johnson ARS N3NPQ [email protected] ([email protected]) Chapel Hill, NC References: cannot get exclusive lock From:

They hope these examples will help you to get a better understanding of the Linux system and that you feel encouraged to try out things on your own. aaa.rpm has dependency on bbb.rpm and ccc.rpm. wget gives warning message about libidn and libiconv wget produces a warning message similar to this one: # wget ... Try that: $ rpm --root /home/prl2/toolbox -Uv coreutils*rpm --nodeps --badreloc /opt=/home/prl2/toolbox coreutils-5.0-1 unpacking of archive failed on file /usr/bin/dir: cpio: symlink failed - Permission denied That error is only because it

Later when I tried to install the same rpm as root I am getting the problem as : Code: root:stud -> $ rpm -i -v python-2.6.7-1.aix5.1.ppc.rpm cannot get exclusive lock on Configuration mode is used for administration of critical, security-relevant parts of the system.Operational mode is the standard system operating mode. Registration on or use of this site constitutes acceptance of our Privacy Policy. http://www.perzl.org/aix/index.php?n=FAQs.FAQs This is now fixed in wget versions starting with: wget 1.12-3 wget 1.13.4-3 configure does not detect shared library capability on AIX V6.1 and V7.1 If configure shows the following output

From: David Clissold - 2004-10-21 01:20:56 Phil, This isn't going to be perfect for you, but I think it will at least get you what you want, which is making Briefly describe the problem (required): Upload screenshot of ad (required): Select a file, or drag & drop file here. ✔ ✘ Please provide the ad click URL, if possible: Home Browse Try that: $ rpm --root /home/prl2/toolbox -Uv coreutils*rpm --nodeps --badreloc /opt=/home/prl2/toolbox coreutils-5.0-1 unpacking of archive failed on file /usr/bin/dir: cpio: symlink failed - Permission denied That error is only because it Main Menu LQ Calendar LQ Rules LQ Sitemap Site FAQ View New Posts View Latest Posts Zero Reply Threads LQ Wiki Most Wanted Jeremy's Blog Report LQ Bug Syndicate Latest

Re: [tbox-l] non-privileged user installs? https://www.ibm.com/developerworks/community/forums/thread.jspa?messageID=14623238 From: Phil Lawrence - 2004-10-21 05:20:13 On Oct 20, 2004, at 18:20, David Clissold wrote: > Phil, > > This isn't going to be perfect for you, but I think Let's try using --relocate: $ rpm --root /home/prl2/toolbox -Uv coreutils*rpm --nodeps --relocate /opt=/home/prl2/toolbox path /opt is not relocateable for package coreutils-5.0-1 The package is not relocatable. OK, I gave it my best shot, but could use a hand: ----------SETUP STUFF-------------------- bash-2.04$ cat bin/setup-rpmbuildroot MYRPMBUILD="myrpmbuild" # Set up build area mkdir \ $HOME/$MYRPMBUILD \ $HOME/$MYRPMBUILD/tmp \ $HOME/$MYRPMBUILD/platform \

libidn: warning: libiconv not installed, cannot convert data to UTF-8 ... http://haywirerobotics.com/error-cannot/error-cannot-open-display-0-0.html Go into your /home/prl2/toolbox directory and you'll see a "freeware/bin" subdirectory that has all the commands you want. If there's one present, kill it. 1 members found this post helpful. If these packages did not come from the AIX Toolbox for Linux Applications, it may be necessary to reinstall them.

An example of an installation : $ id uid=202(sa) gid=1(staff) $ rolelist -e sa System Administrator so System Operator isso Information System Security Officer AccountAdmin User and Group Account Administration FSAdmin I did a little experimenting, and here is what I came up with. Topic Forum Directory >‎ dW >‎ AIX and UNIX >‎ Forum: AIX Forum >‎ Topic: Install software on AIX with Trusted AIX option No replies Display:ConversationsBy Date 1-1 of 1 Previous http://haywirerobotics.com/error-cannot/error-cannot-open-directory-for-uri.html That said, if you just killed the terminal window, the process may be hung.

The $ sign indicates a normal user. –Khaled Jan 13 '13 at 14:20 @dchirikov : I get lsof: WARNING: compiled for AIX version 5.1.0.0; this is 6.1.0.0. –gautam vegeta eserver and other IBM related questions are also on topic. TB0ne View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by TB0ne 01-13-2013, 01:05 PM #3 gaugeta LQ Newbie Registered: Jan 2013 Posts:

Go into your /home/prl2/toolbox directory and you'll see a "freeware/bin" subdirectory that has all the commands you want.

  • On Wed, Oct 20, 2004 at 12:46:37PM -0400, Phil Lawrence wrote: > On Oct 20, 2004, at 10:26, Phil Lawrence wrote: > > I've searched the archive of this list, but
  • a package that contains other packages.
  • Password AIX This forum is for the discussion of IBM AIX.

I have seen an option like prefix ... In this case you should check the following items: Make sure that your autoconf, automake, libtool, m4 versions are not older than January, 2008! This requires also libidn to be compiled with GNU libiconv support which was not the case before. Check for an rpm command running/defunct with a "ps -ef | grep -i rpm", and see what it tells you.

Downloading RPMs contained in a RPM dependency list How to download the files contained in a RPM dependency lists? Why is (a % 256) different than (a & 0xFF)? Worked perfectly. check over here Not sure why it is not happening here...

I need the functionality of gettext >= 0.17 No, you don't. This can become quite annoying and time-consuming for packages with lots of dependencies. This is what I got from the docs "Configuration mode is used to maintain and recover the system. Drawing a torso with a head (using \draw) Do I need to provide a round-trip ticket in check-in?

Also I did it all on the command line w/o using the .rpmrc config file: $ mkdir /home/prl2/toolbox $ rpm --root /home/prl2/toolbox -Uv coreutils*rpm failed to open /home/prl2/toolbox/var/opt/freeware/lib/rpm/packages.rpm: No such file Your private and currently empty # database that is. # Work around the above fact echo "provides: /bin/sh" > $HOME/.rpmrc ----------------------------------------- ----------THE ATTEMPT-------------------- bash-2.04$ pwd /home/prl2 bash-2.04$ ls -l coreutils-5.0-1.aix5.1.ppc.rpm -rw------- Unfortunately, I have so far found no way of compiling and providing YUM for AIX that could be done in a compatible manner (to the IBM provided RPM) as AIX still rs6000-ibm-aix ...

Instead of making a virtual package, let's just install with --nodeps to ignore dependency-checking, $ rpm --root /home/prl2/toolbox -Uv coreutils*rpm --nodeps coreutils-5.0-1 unpacking of archive failed on file /opt/freeware/bin/basename: cpio: open If you need to reset your password, click here. This is actually where a tool like yum is helping you a lot because it does all the steps outlined above for you. Notices Welcome to LinuxQuestions.org, a friendly and active Linux Community.

RE: How to administer an AIX with Trusted AIX itsp1965 (IS/IT--Management) 1 Jun 11 16:15 www.redbooks.ibm.com - AIX guides for practically everything can be found here. gaugeta View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by gaugeta 01-13-2013, 11:52 AM #2 TB0ne LQ Guru Registered: Jul 2003 Location: checking whether to build shared libraries... Also I did it all on the command line w/o using the .rpmrc config file: $ mkdir /home/prl2/toolbox $ rpm --root /home/prl2/toolbox -Uv coreutils*rpm failed to open /home/prl2/toolbox/var/opt/freeware/lib/rpm/packages.rpm: No such file

Please don't fill out this field.