Home > Error Cannot > Install Ruby Gems

Install Ruby Gems


Installing ri documentation for mongrel_cluster-1.0.5... Not the answer you're looking for? Posted by Sam Ruby at 23:28 Mon 24 Nov 2008 In order to avoid conflicts with system updates wouldn't it make more sense to change GEM_HOME to allow non-super install? To see the progress of this discussion, visit the rubygems-trust organization on GitHub. http://haywirerobotics.com/error-cannot/ruby-rexml-example.html

Excerpt from watir Tutor and Interview Questions at 06:45 Mon 03 May 2010 在 Ubuntu 8.04 上裝 Redmine 0.9.x 關鍵在於 Redmine 0.9.x 需要 rails 2.3.5, 而 rails 2.3.5 需要 rubygems v1.3.1 Installing RDoc documentation for mongrel-1.1.5... RBTree is a subclass of MultiRBTree. ------------------------------------------- You can view the documentation for your installed gems in your browser with the server command: $ gem server Server started at Server Please `gem update --system` and try again. 11. http://stackoverflow.com/questions/1954206/cant-update-rubygems

Install Ruby Gems

So I went for another solution, which installs more then necesary but is more straighforward: Install a more recent version of ruby + irb + rdoc + gem (side by side If that doesnt' work... :) I might do the drastic and rebuild Ruby as well. If you read default.rb (I am not at my ubuntu box as I write this) it seems that the rubygems guys know about the debian /var/lib/gem path but don't adjust the We also answer questions on the RubyGems Support site and on IRC in #rubygems.

Excerpt from Delicious/mcandre/rubygems at 02:45 Mon 25 May 2009 Instalando Community Engine (1) Community Engine es un plugin de Ruby On Rails . Are people using the supplied 1.8.7? Excerpt from Comments on: Rails 2.1.2 and 2.2RC1: Update Your RubyGems at 20:15 Sat 17 Jan 2009 [rails][ruby]gemの1.3にあげれなかった railsを2.2.2にしたら empty?が未定義とかいわれた .Text - Error encountered なんか、2.1.2 にしたら script/generate ができなくなりました。 ruby script/generate model Failed To Build Gem Native Extension gem uninstall rubygems-update Mentioned fix of missing line successfully updated the rubygems. Sign up for free to join this conversation on GitHub.

Still fails $ ruby script/console Loading development environment (Rails 2.3.3) Rails requires RubyGems >= 1.3.1 (you have 1.0.1). Operation Not Permitted - /usr/bin/update_rubygems Worked on a Mac OS X when the gem install/update commands didn't take. –Ryan Sep 23 '11 at 17:29 The link is dead, change to this perhaps: rubygems.org/pages/download –oskarth For anyone else having this problem this is what I did that worked:1. Since that's the case...

Skip to content Ignore Learn more Please note that GitHub no longer supports old versions of Firefox. Rbenv It was working fine until I needed to update RubyGems 1.0.1 to 1.3.5. mingle About Twitter Comments Register Statistics Archives Planet Code Rails RESTful Disclaimer HTTP RFC 2616 httpbis URI RFC 3986 URI Template HTML Working Group WHATWG Specs HTML 4.01 XHTML 1.0 Drafts https://help.ubuntu.com/community/RubyOnRails#RubyGems 1.3.1 Posted by Nick Hammond at 21:41 Sun 29 Nov 2009 Social comments and analytics for this post This post was mentioned on Twitter by marcheiligers: Update rubygems on Ubuntu

  1. This is not the normal problem!
  2. Already have an account?
  3. Thanks!
  4. Excerpt from LifeAtMyMind at 20:46 Mon 12 Jan 2009 By: Ben Wagaman I am current using Ubuntu 8.10.
  5. A false return from the require method does not indicate an error.
  6. share|improve this answer answered Dec 23 '09 at 18:24 BigBrother 5651616 Thanks dude:) Yup, i ran all the commands with sudo.
  7. still, to save yourself some trouble.
  8. When you do the /var/lib/gems/1.8/bin/update_rubygems to go to 1.3.1 the update will ignore the debian gem home and use a combination of /usr/lib/gem and $HOME/.gem as the GEM_PATHs so any gems
  9. Let’s try this out in irb and get some help from the pretty_print library included with Ruby.

Operation Not Permitted - /usr/bin/update_rubygems

You can probably fix this by adjusting a symlink: $ ls -l /usr/local/bin/ruby* lrwxr-xr-x 1 root wheel 76 Jan 20 2010 /usr/local/bin/[email protected] -> /usr/local/bin/ruby1.8 -rwxr-xr-x 1 root wheel 1213160 Jul 15 http://guides.rubygems.org/faqs/ Here's the gems environment: RubyGems Environment: - RUBYGEMS VERSION: 1.1.1 - RUBY VERSION: 1.8.6 (2008-08-11 patchlevel 287) [universal-darwin9.0] - INSTALLATION DIRECTORY: /Library/Ruby/Gems/1.8 - RUBY EXECUTABLE: /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby - RUBYGEMS PLATFORMS: - ruby Install Ruby Gems You can use regular expression characters in your query: $ gem search ^rails *** REMOTE GEMS *** rails (4.0.0) rails-3-settings (0.1.1) rails-action-args (0.1.1) rails-admin (0.0.0) rails-ajax ( [...] If you see Gem Update Posted by Mike at 20:32 Sat 21 Feb 2009 after updating gem using the update-rubygems gem, it was impossible to show "gem list" is the only output.

The commands provided by the gems you installed will end up in ~/.gem/ruby/1.9.1/bin. You may want to read HiveLogic article on installing Ruby, RubyGems, etc on Mac OS Snow Leopard. On a dev box, I hate having to do sudo gem install to get gems for user space stuff. The -S argument finds rake in the shell’s $PATH so you don’t have to type out the full path. Gem Install Specific Version

RubyGems has already been updated. Tried command again to no avail... $ script/console Loading development environment (Rails 2.3.3) Rails requires RubyGems >= 1.3.1 (you have 1.0.1). We recommend upgrading to the latest Safari, Google Chrome, or Firefox. weblink What’s wrong?

I am running Mac OS X Leopard on an iMac G5 . You Don't Have Write Permissions For The /library/ruby/gems/2.0.0 Directory. Console still won't work $ script/console Loading development environment (Rails 2.3.3) Rails requires RubyGems >= 1.3.1 (you have 1.0.1). I've tried the following: gem update Result: Updating installed gems Bulk updating Gem source index for: http://gems.rubyforge.org/ Nothing to update and gem install rubygems-update Result: Bulk updating Gem source index for:

If that doesn't work, download gems source again and rebuild from scratch (may want to erase prior source download, etc).

Installing RDoc documentation for actionmailer-2.2.2... Not every library has a strict mapping between the name of the gem and the name of the file you need to require. Thus I created a new rails project and testedd from within it... Rvm Install Still won't work. $ rails -d postgresql testing create create app/controllers create app/helpers create app/models create app/views/layouts create config/environments create config/initializers create config/locales create db create doc create lib create lib/tasks

Installing RDoc documentation for rails-2.3.3... Please `gem update --system` and try again. Some of the information you can find on the support site includes: Installing gems with no network Why do I get HTTP Response 302 or 301 when installing a gem? check over here cheers!

just go in, locate the bin-directory and start update_rubygems from there. This was a virgin ubuntu 8.10 system. Reload to refresh your session. Excerpt from tail -f log/development.log at 09:17 Sun 08 Feb 2009 You da man.

RubyGems has already been updated. You can disable documentation generation using the --no-doc argument when installing gems. So you'll use sudo gem install rubygems-update and sudo update_rubygems. look into your path-variables and make sure everything is working correctly.

E.g. Posted by Joe at 19:56 That's a better error message than I get on Hardy. $ sudo gem update --system Updating RubyGems Nothing to update $ sudo gem update --debug --system If you’re requiring the correct file, maybe gem is using a different ruby than ruby: $ which ruby /usr/local/bin/ruby $ gem env | grep 'RUBY EXECUTABLE' - RUBY EXECUTABLE: /usr/local/bin/ruby1.9 In To recap: If you've already tried to update, uninstall the latest rubygems-update first: sudo gem uninstall rubygems-update -v 1.3.5 Update to 1.3.0: sudo gem install rubygems-update -v 1.3.0 sudo update_rubygems Then

Quit server of current project and restarted the computer10.